Big Commerce Login/Trial Banner
Incident Report for Signifyd
Resolved
Some users using the Big Commerce extension may have incorrectly received the Free Trial banner at the top of the console. Refreshing your browser will resolve this.

For any questions, please reach out to support@signifyd.com
Posted Sep 16, 2016 - 12:07 PDT
Investigating
Some users using the Big Commerce extension may incorrectly receive the Free Trial banner at the top of the console. We are currently investigating.

Please note: we are still receiving all orders and providing scores and guarantee decisions.
Posted Sep 16, 2016 - 09:09 PDT