Case Processing Delay
Incident Report for Signifyd
Resolved
This incident has been resolved.
Posted Jan 17, 2019 - 09:58 PST
Identified
We have been experiencing a delay in processing of submitted cases due to an intermittent operation issue. All cases are being submitted successfully and queued, but you may notice a slight delay in response and score while we process the backlog. All submitted backlogged orders are expected to be fully processed.

Should you have any questions, please contact us via the support link under the Help section.
Posted Jan 17, 2019 - 09:18 PST
This incident affected: Order Review.