Some users unable to submit claims
Incident Report for Signifyd
Resolved
This issue is resolved now. Please let us know at support@signifyd.com if you notice any issue.
Posted Mar 21, 2017 - 12:18 PDT
Identified
Some users reported they are unable to submit claims. We are working on the fix and this should be resolved shortly.
Posted Mar 21, 2017 - 09:26 PDT