Marketing website down.
Incident Report for Signifyd
Resolved
Website operational again
Posted Mar 15, 2017 - 15:14 PDT
Identified
Our hosting provider is experiencing connectivity issues that are resulting in down sites at that data center. Our platform is unaffected and can be reached at https://app.signifyd.com/
Posted Mar 15, 2017 - 13:45 PDT