Some users unable to submit claims
Incident Report for Signifyd
Resolved
This issue has now been resolved. Please let us know at support@signifyd.com if you notice any further issues.
Posted Oct 19, 2017 - 08:50 PDT
Identified
Some users reported they are unable to submit claims. We are working on the fix and this should be resolved shortly.
Posted Oct 19, 2017 - 08:21 PDT